I will patch php2shell and upgrade PHP without breaking your wordpress


About this gig
HP2Shell (CVE-2026-109618 / 109619, CVSS 9.2) lets attackers run code on your WordPress server without logging in, and it's being exploited now. I patch it and prove it, without breaking your site.
THE CATCH MOST GIGS SKIP
PHP 8.2-8.5 just need the patched build. PHP 8.1, 8.0 and 7.x get NO patch: you must upgrade, and that's where old plugins and themes break. That's the part I fix.
WHAT I DO
Free check: are you affected? (send your PHP version)
Full backup + staging copy before any change
Update to 8.2.35 / 8.3.36 / 8.4.27 / 8.5.12
Fix fatal errors, white screens, plugin & theme conflicts
Replace abandoned plugins that won't run on new PHP
Interim mitigation if you can't upgrade today
WHAT YOU GET
Proof: before/after PHP version and config check
Your site tested: pages, forms, login, checkout
Written rollback steps
Plain-English report of every change
WORKS ON
WordPress WooCommerce Elementor cPanel Plesk VPS LiteSpeed PHP-FPM
Respect third-party rights
Please be aware that it is against Fiverr's policies for sellers to include themes, templates, or any other elements that infringe third-party rights or applicable laws in the delivered work. Read more about in our Guide to Responsible Digital Creation.
Get to know Andri D
- FromIndonesia
- Member sinceNov 2020
- Avg. response time1 hour
Languages
English, Indonesian
FAQ
Am I affected?
If your site runs PHP and serves web pages, probably yes, unless you're already on 8.2.35, 8.3.36, 8.4.27 or 8.5.12 or later. Send me your version and I'll check it for free.
My host says they patched it. Do I still need this?
Maybe not. Managed hosts often patch the PHP build for you. I'll verify it free, and if you're safe, I'll tell you.
I'm on PHP 7.4 / 8.0 / 8.1. Can you just patch it?
No. Those versions are end-of-life and have no fix. You need to upgrade, which is the End-of-life Rescue package.
Will the upgrade break my site?
It can, which is why I work on a staging copy first and fix every error before going live. You also get rollback steps.
Do you need root or SSH access?
For a VPS, yes, SSH access. On cPanel or Plesk, panel access plus WordPress admin is usually enough. Access goes through Fiverr's secure channel, and I recommend changing passwords after delivery.
My site is Laravel or custom PHP, not WordPress?
Message me. My Laravel / PHP bug-fixing gig covers PHP2Shell for those apps.
Is this a full security audit or pentest?
No. This gig patches PHP2Shell and makes your WordPress site work on a supported PHP version. Ask me if you need a broader security review.
