I will secure and update your wordpress or woocommerce site after the php2shell exploit
Level 2
About this gig
Two critical PHP vulnerabilities (CVE-2026-109618 and CVE-2026-109619, known as php2shell) allow attackers to run code on any site with an unpatched PHP version. WordPress, WooCommerce and Laravel sites are all affected. Patched versions: PHP 8.2.35, 8.3.36, 8.4.27 and 8.5.12. Older PHP versions get no fix and must be upgraded.
What I do:
- Check which PHP version your site runs and whether it is vulnerable
- Switch to a patched PHP version in your hosting panel and test your site afterwards
- Update WordPress core, plugins and themes, and remove what is no longer used
- Security scan, backup and hardening: file permissions, admin access, security plugin
- Hacked already? I remove the malware, replace the core files, check the database and get your site back online
How I work:
- Backup first, always
- You get a short report of what I found and what I changed
- Access via a temporary admin account or your hosting panel. You never share your main password.
I have cleaned up hacked WordPress and WooCommerce sites for years and manage hosting for my own clients.
Based in the Netherlands, in English or Dutch. Message me with your site URL first.
Respect third-party rights
Please be aware that it is against Fiverr's policies for sellers to include themes, templates, or any other elements that infringe third-party rights or applicable laws in the delivered work. Read more about in our Guide to Responsible Digital Creation.
Get to know Athbi
Your ecommerce partner for build, fix and growth
Level 2
- FromNetherlands
- Member sinceJun 2016
- Avg. response time3 hours
- Last delivery3 weeks
Languages
English, Dutch
FAQ
How do I know if my site is affected?
If your site runs PHP and has not been updated since 21 October 2026, assume it is. In the Basic package I check your PHP version and tell you within a day whether you are safe.
My hosting company says they updated the servers. Do I still need this?
Often yes. Hosts patch the PHP versions they still support. If your site runs an old version (8.1 or lower), there is no patch for it and you need to switch to a newer version and test the site.
Will the PHP update break my site?
It can, if you use old plugins or themes. That is why I test the site after the switch and fix what breaks, or roll back and tell you what needs to be updated first.
My site is already hacked. What do you need?
Your site URL, access to the hosting panel or FTP, and WordPress admin access. I take a backup, clean the files and the database, update everything and send you a report. Order Premium or message me first.
Do you work with WooCommerce and Laravel too?
Yes. WooCommerce is WordPress, so everything applies. For Laravel or custom PHP sites, message me first with the stack, so I can confirm what I can do.
Do you work in Dutch?
Yes. I am based in the Netherlands and work in Dutch and English, in the EU timezone.
